Proxy setting

Answered

Hey,

I am usually working from school. And, I must set the proxy settings to be able to use all the features of Jetbrains IDEs.

For instance, I used to set the HTTP Proxy on IntelliJ, or WebStorm.

However, Fleet doesn't have that setting, and I'm missing it.

Thank you in advance.

3
7 comments

There are no proxy settings yet. We will add them in nearest Fleet updates: FL-12408 Fleet should support proxies

Could you describe please which functionality in Fleet does not work for you? Thank you.

0

Thank you for your quick answer.

It's an actual when I try to use the VCS integration. Each time I want to perform an action related to git, it asks me my token and when I submit it, an error occurs telling me that it couldn't connect to a server (I assume related to GitHub).

And since my proxy setting is configured with the git command line (and the git command line works perfectly) it's related to Fleet and probably the HTTP Proxy setting that exists on all the other IDEs on which I have no problem with git at all.

Anyways, I will either way need this setting (personally but everyone else that is subject to a proxy as well) to take advantage of the entire Fleet experience.

0

Fleet now supports proxy via usual environment variables http_proxyhttps_proxy and no_proxy and their capitalised alternatives HTTP_PROXYHTTPS_PROXY and NO_PROXY, full system proxy support will come later in FL-16390.

0

Thank you very much :)

0

How do I configure the proxy settings? Fleet responds with “no internet connection” for me.

0

rj.ipseo.net they don't answer old issues, I highly adivse you to create a new one :)

0

We answer all the questions /issues, but it is better to create a new separate thread for each question/problem since it could be a different problem/cause and so the solution could be different. Such threads would be much easier to read and find the appropriate solution. Thank you for understanding!

0

Please sign in to leave a comment.