Snippets or Live-Templates


Are there any plans to bring the snippets / live-templates option to fleet? I currently use PyCharm as well as DataSpell. I would love to completely move to fleet with my entire team. But we miss some features just as live-templates, integrated terminal, etc. Are there any plans on integrating those features? Or they are already here, in which case I would ask, how can I use them.


The current option is to have a text mate or vs code bundle installed in ~/.fleet/textmate. Fleet will load snippets from such bundles as well.

For built-in support, please vote and follow this request: FL-11905 Custom live templates for fleet


in ~/.fleet/textmate. Fleet will load snippets from such bundles as well.

This method does not work for me when I place a VS Code bundle into ~/.fleet/textmate. Is there more detailed information about how to achieve this?


1249736473 could you clarify your steps, please? What bundle you put and how do you try to use it in Fleet? Thank you.


I try to add my custom live templates(snippets) by following steps:

1. Firstly, I package the vscode snippets into the following structure:

2. And then, I place the whmod-snippet into ~/.fleet/textmate, just like:

3. Finally, I restart Fleet but nothing happened.


Looking forward to your reply.

Thank you.


You need to place full bundle package (the `.tmBundle` extension) into `./fleet/textmate` directory, where the bundle must have the scope defined. E.g. here is the text mate snippet, with the scope defined to .dart files:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
<plist version="1.0">
	<string>Hello ${1|world,universe|}</string>

Thank you for your answer.

According to your suggestion, I tried to import an exist textmate bundle to Fleet by run following commands under ~/.fleet/textmate:

git clone "CSS3.tmbundle"

then I restart Fleet and create a new css file  but the snippet still not work. Is there anything wrong with above process?

Here is the directory structure of ~/.fleet:

All snippets have the scope defined:

And I also try to add the scope defined into the info.plist after the first failure, but it still not work for me.


Please sign in to leave a comment.